transmission-remote-gtk-1.0.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit gnome2-utils
  5. DESCRIPTION="GTK client for management of the Transmission BitTorrent client, over HTTP RPC"
  6. HOMEPAGE="https://code.google.com/p/transmission-remote-gtk"
  7. SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE="debug geoip libproxy unique"
  12. RESTRICT="test"
  13. RDEPEND=">=dev-libs/glib-2.22:2
  14. >=dev-libs/json-glib-0.12.2
  15. unique? ( dev-libs/libunique:1 )
  16. libproxy? ( net-libs/libproxy )
  17. net-misc/curl
  18. >=x11-libs/gtk+-2.16:2
  19. x11-libs/libnotify
  20. geoip? ( dev-libs/geoip )"
  21. DEPEND="${RDEPEND}
  22. dev-util/intltool
  23. virtual/pkgconfig"
  24. DOCS=( AUTHORS README )
  25. src_configure() {
  26. # disable gtk3 for now because upstream doesn't consider it "ready".
  27. # Also disable libappindicator till gtk3 is ready since ayatana on
  28. # gtk2 is deprecated in Gentoo.
  29. econf \
  30. $(use_enable debug) \
  31. $(use_with geoip libgeoip) \
  32. $(use_with libproxy) \
  33. $(use_with unique libunique) \
  34. --without-libappindicator \
  35. --disable-gtk3
  36. }
  37. pkg_preinst() { gnome2_icon_savelist; }
  38. pkg_postinst() { gnome2_icon_cache_update; }
  39. pkg_postrm() { gnome2_icon_cache_update; }