telepathy-rakia-0.8.0.ebuild 926 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python2_7 )
  5. inherit python-single-r1
  6. DESCRIPTION="A SIP connection manager for Telepathy based around the Sofia-SIP library"
  7. HOMEPAGE="https://telepathy.freedesktop.org/"
  8. SRC_URI="https://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
  9. LICENSE="LGPL-2.1"
  10. SLOT="0"
  11. KEYWORDS="~alpha amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc x86 ~x86-linux"
  12. IUSE="test"
  13. COMMON_DEPEND="
  14. >=dev-libs/dbus-glib-0.60
  15. >=dev-libs/glib-2.30:2
  16. >=net-libs/sofia-sip-1.12.11
  17. >=net-libs/telepathy-glib-0.17.6
  18. >=sys-apps/dbus-0.60
  19. "
  20. RDEPEND="${COMMON_DEPEND}
  21. !net-voip/telepathy-sofiasip
  22. "
  23. # telepathy-rakia was formerly known as telepathy-sofiasip
  24. DEPEND="${COMMON_DEPEND}
  25. dev-libs/libxslt
  26. test? ( dev-python/twisted-core )
  27. "
  28. # eautoreconf requires: gtk-doc-am
  29. src_configure() {
  30. econf --disable-fatal-warnings
  31. }