wcalc-2.5.ebuild 664 B

12345678910111213141516171819202122232425262728293031323334
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit eutils
  5. DESCRIPTION="A flexible command-line scientific calculator"
  6. HOMEPAGE="http://w-calc.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/w-calc/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
  11. IUSE="readline"
  12. RDEPEND="
  13. dev-libs/gmp:0=
  14. dev-libs/mpfr:0=
  15. readline? ( sys-libs/readline:0= )"
  16. DEPEND="${RDEPEND}"
  17. src_configure() {
  18. econf $(use_with readline)
  19. }
  20. src_install() {
  21. default
  22. # Wcalc icons
  23. newicon graphics/w.png wcalc.png
  24. newicon graphics/Wred.png wcalc-red.png
  25. }