Shapely-1.5.17.ebuild 698 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. PYTHON_COMPAT=( python{2_7,3_{4,5}} )
  5. inherit distutils-r1
  6. DESCRIPTION="Geometric objects, predicates, and operations"
  7. HOMEPAGE="https://pypi.python.org/pypi/Shapely"
  8. if [[ ${PV} == "9999" ]] ; then
  9. inherit git-r3
  10. SRC_URI=""
  11. EGIT_REPO_URI="https://github.com/Toblerity/${PN}.git"
  12. else
  13. SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
  14. KEYWORDS="~amd64 ~x86"
  15. fi
  16. LICENSE="BSD"
  17. SLOT="0"
  18. IUSE="test"
  19. RDEPEND=">=sci-libs/geos-3.1"
  20. DEPEND="${RDEPEND}
  21. dev-python/setuptools[${PYTHON_USEDEP}]
  22. test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
  23. python_test() {
  24. esetup.py test
  25. }