adolc-2.5.0.ebuild 984 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. AUTOTOOLS_AUTORECONF=yes
  5. #AUTOTOOLS_IN_SOURCE_BUILD=yes
  6. inherit autotools-utils toolchain-funcs
  7. MYPN=ADOL-C
  8. DESCRIPTION="Automatic differentiation system for C/C++"
  9. HOMEPAGE="https://projects.coin-or.org/ADOL-C/"
  10. SRC_URI="http://www.coin-or.org/download/source/${MYPN}/${MYPN}-${PV}.tgz"
  11. LICENSE="|| ( EPL-1.0 GPL-2 )"
  12. SLOT="0/1"
  13. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  14. IUSE="mpi sparse static-libs"
  15. RDEPEND="mpi? ( sys-cluster/ampi:0= )
  16. sparse? ( sci-libs/colpack:0= )"
  17. DEPEND="${RDEPEND}"
  18. S="${WORKDIR}/${MYPN}-${PV}"
  19. PATCHES=(
  20. "${FILESDIR}"/${PN}-2.5.0-no-colpack.patch
  21. "${FILESDIR}"/${PN}-2.5.0-pkgconfig-no-ldflags.patch
  22. )
  23. src_configure() {
  24. local myeconfargs=(
  25. $(use_enable mpi ampi)
  26. $(use_enable sparse)
  27. $(use_with sparse colpack "${EPREFIX}"/usr)
  28. )
  29. autotools-utils_src_configure
  30. }
  31. src_test() {
  32. autotools-utils_src_test test
  33. }