fcl-0.4.0.ebuild 856 B

123456789101112131415161718192021222324252627282930313233343536373839404142
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. SCM=""
  5. if [ "${PV#9999}" != "${PV}" ] ; then
  6. SCM="git-r3"
  7. EGIT_REPO_URI="https://github.com/flexible-collision-library/fcl"
  8. fi
  9. inherit ${SCM} cmake-utils
  10. if [ "${PV#9999}" != "${PV}" ] ; then
  11. KEYWORDS=""
  12. SRC_URI=""
  13. else
  14. KEYWORDS="~amd64 ~arm"
  15. SRC_URI="https://github.com/flexible-collision-library/fcl/archive/${PV}.tar.gz -> ${P}.tar.gz"
  16. fi
  17. DESCRIPTION="The Flexible Collision Library"
  18. HOMEPAGE="http://gamma.cs.unc.edu/FCL/"
  19. LICENSE="BSD"
  20. SLOT="0"
  21. IUSE="cpu_flags_x86_sse"
  22. RDEPEND="
  23. sci-libs/octomap
  24. sci-libs/flann
  25. dev-libs/boost:=[threads]
  26. sci-libs/libccd"
  27. DEPEND="${RDEPEND}
  28. virtual/pkgconfig"
  29. src_configure() {
  30. local mycmakeargs=(
  31. "-DFCL_USE_SSE=$(usex cpu_flags_x86_sse TRUE FALSE)"
  32. )
  33. cmake-utils_src_configure
  34. }