htslib-1.3.ebuild 477 B

123456789101112131415161718192021
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. DESCRIPTION="C library for high-throughput sequencing data formats"
  5. HOMEPAGE="http://www.htslib.org/"
  6. SRC_URI="mirror://sourceforge/samtools/${PV}/${P}.tar.bz2"
  7. SLOT="0"
  8. LICENSE="MIT"
  9. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  10. IUSE="static-libs"
  11. src_install() {
  12. default
  13. if ! use static-libs; then
  14. find "${ED}" -type f -name "*.a" -delete || die
  15. fi
  16. }