libctl-3.2.ebuild 744 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit fortran-2 autotools-utils
  5. DESCRIPTION="Guile-based library for scientific simulations"
  6. HOMEPAGE="http://ab-initio.mit.edu/libctl/"
  7. SRC_URI="http://ab-initio.mit.edu/libctl/${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="doc examples static-libs"
  12. DEPEND="
  13. dev-scheme/guile
  14. sci-libs/nlopt"
  15. RDEPEND="${DEPEND}"
  16. src_install() {
  17. autotools-utils_src_install
  18. use doc && dohtml doc/*
  19. if use examples; then
  20. insinto /usr/share/doc/${PF}/examples
  21. doins "${AUTOTOOLS_BUILD_DIR}"/examples/{*.c,*.h,example.scm,Makefile}
  22. doins "${S}"/examples/{README,example.c,run.ctl}
  23. fi
  24. }