libdap-3.11.3.ebuild 981 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools-utils
  5. DESCRIPTION="Implementation of a C++ SDK for DAP 2.0 and 3.2"
  6. HOMEPAGE="http://opendap.org/"
  7. SRC_URI="http://www.opendap.org/pub/source/${P}.tar.gz"
  8. LICENSE="|| ( LGPL-2.1 URI )"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
  11. IUSE="doc static-libs test"
  12. RDEPEND="
  13. dev-util/cppunit
  14. dev-libs/libxml2:2
  15. net-misc/curl
  16. sys-libs/zlib
  17. "
  18. DEPEND="${RDEPEND}
  19. doc? ( app-doc/doxygen )
  20. test? ( dev-util/cppunit )
  21. "
  22. DOCS=( README NEWS README.dodsrc )
  23. RESTRICT="test"
  24. # needs http connection
  25. # FAIL: MIMEUtilTest
  26. PATCHES=( "${FILESDIR}"/${P}-gcc-4.7.patch )
  27. src_compile() {
  28. autotools-utils_src_compile
  29. use doc && autotools-utils_src_compile docs
  30. }
  31. src_test() {
  32. emake check
  33. cd "${S}"/unit-tests
  34. emake check
  35. }
  36. src_install() {
  37. use doc && HTML_DOCS=("${AUTOTOOLS_BUILD_DIR}/docs/html/")
  38. autotools-utils_src_install
  39. }