libexcelformat-101016.ebuild 580 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2010 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit multilib toolchain-funcs
  5. DESCRIPTION="reading, writing, and editing of XLS (BIFF8 format) files using C++"
  6. HOMEPAGE="http://www.codeproject.com/KB/office/ExcelFormat.aspx"
  7. SRC_URI="mirror://gentoo/${P}.tar.bz2"
  8. SLOT="0"
  9. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  10. LICENSE="CPOL"
  11. IUSE=""
  12. S="${WORKDIR}"/libExcelFormat
  13. src_prepare() {
  14. tc-export CXX
  15. }
  16. src_install() {
  17. insinto /usr/include
  18. doins *.h* || die
  19. dolib.so libExcelFormat.so* || die
  20. }