libgenome-1.3-r1.ebuild 692 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit autotools
  5. DESCRIPTION="Library for sci-biology/mauve"
  6. HOMEPAGE="http://gel.ahabs.wisc.edu/mauve/"
  7. SRC_URI="mirror://gentoo/${PF}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. IUSE="doc static-libs"
  11. KEYWORDS="~amd64 ~x86"
  12. DEPEND="doc? ( app-doc/doxygen )"
  13. RDEPEND=""
  14. PATCHES=( "${FILESDIR}/${PN}-1.3-fix-c++14.patch" )
  15. src_prepare() {
  16. default
  17. rm libGenome/gnDefs.cpp || die
  18. eautoreconf
  19. }
  20. src_configure() {
  21. econf \
  22. --enable-shared \
  23. $(use_enable static-libs static)
  24. }
  25. src_install() {
  26. default
  27. # package provides .pc files
  28. find "${D}" -name '*.la' -delete || die
  29. }