libticables2-1.3.3-r1.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils multilib
  5. DESCRIPTION="Library to handle different link cables for TI calculators"
  6. HOMEPAGE="http://lpg.ticalc.org/prj_tilp/"
  7. SRC_URI="mirror://sourceforge/tilp/tilp2-linux/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
  11. IUSE="debug doc nls static-libs usb"
  12. RDEPEND="
  13. dev-libs/glib:2
  14. usb? ( virtual/libusb:1 )
  15. nls? ( virtual/libintl )"
  16. DEPEND="${RDEPEND}
  17. virtual/pkgconfig
  18. nls? ( sys-devel/gettext )"
  19. DOCS=( AUTHORS LOGO NEWS README ChangeLog docs/api.txt )
  20. src_configure() {
  21. # --disable-libusb $(use_enable usb libusb10) would enable virtual/libusb:1
  22. econf \
  23. --disable-rpath \
  24. $(use_enable debug logging) \
  25. $(use_enable nls) \
  26. $(use_enable static-libs static) \
  27. $(use_enable usb libusb) \
  28. $(use_enable usb libusb10)
  29. }
  30. src_install() {
  31. default
  32. use doc && dohtml docs/html/*
  33. use static-libs || rm -f "${ED}"/usr/$(get_libdir)/${PN}.la
  34. }
  35. pkg_postinst() {
  36. elog "Please read README in /usr/share/doc/${PF}"
  37. elog "if you encounter any problem with a link cable"
  38. }