tnt-1.2.6.ebuild 635 B

1234567891011121314151617181920212223242526272829303132
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit versionator
  5. MYP="${PN}$(replace_all_version_separators '')"
  6. DOCPV=120
  7. DESCRIPTION="Template Numerical Toolkit: C++ headers for array and matrices"
  8. HOMEPAGE="http://math.nist.gov/tnt/"
  9. SRC_URI="http://math.nist.gov/tnt/${MYP}.zip
  10. doc? ( http://math.nist.gov/tnt/${PN}${DOCPV}doc.zip )"
  11. LICENSE="public-domain"
  12. SLOT="0"
  13. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  14. IUSE="doc"
  15. DEPEND="app-arch/unzip"
  16. RDEPEND=""
  17. S="${WORKDIR}"
  18. src_install() {
  19. insinto /usr/include
  20. doins *.h
  21. use doc && dohtml html/*
  22. }