fitsverify-4.18.ebuild 734 B

1234567891011121314151617181920212223242526272829303132333435
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="FITS file format checker"
  6. HOMEPAGE="http://heasarc.gsfc.nasa.gov/docs/software/ftools/fitsverify/"
  7. SRC_URI="${HOMEPAGE}/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND="sci-libs/cfitsio:0="
  13. DEPEND="${RDEPEND}
  14. virtual/pkgconfig"
  15. S="${WORKDIR}/${PN}"
  16. src_compile() {
  17. $(tc-getCC) ${CPPFLAGS} -DSTANDALONE ${CFLAGS} ${LDFLAGS} \
  18. $($(tc-getPKG_CONFIG) --cflags cfitsio) \
  19. ftverify.c fvrf*.c \
  20. $($(tc-getPKG_CONFIG) --libs cfitsio) -o ${PN} \
  21. || die "compiled failed"
  22. }
  23. src_install() {
  24. dobin fitsverify
  25. dodoc README
  26. }