automake-1.13.4.ebuild 2.2 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="Used to generate Makefile.in from Makefile.am"
  6. HOMEPAGE="https://www.gnu.org/software/automake/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
  8. LICENSE="GPL-2"
  9. # Use Gentoo versioning for slotting.
  10. SLOT="${PV:0:4}"
  11. KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
  12. IUSE=""
  13. RDEPEND="dev-lang/perl
  14. >=sys-devel/automake-wrapper-10
  15. >=sys-devel/autoconf-2.69
  16. sys-devel/gnuconfig"
  17. DEPEND="${RDEPEND}
  18. sys-apps/help2man"
  19. src_prepare() {
  20. export WANT_AUTOCONF=2.5
  21. epatch "${FILESDIR}"/${PN}-1.13-dyn-ithreads.patch
  22. sed -i -e "/APIVERSION=/s:=.*:=${SLOT}:" configure || die
  23. }
  24. src_configure() {
  25. econf --docdir="\$(datarootdir)/doc/${PF}"
  26. }
  27. src_test() {
  28. emake check
  29. }
  30. # slot the info pages. do this w/out munging the source so we don't have
  31. # to depend on texinfo to regen things. #464146 (among others)
  32. slot_info_pages() {
  33. pushd "${ED}"/usr/share/info >/dev/null
  34. rm -f dir
  35. # Rewrite all the references to other pages.
  36. # before: * aclocal-invocation: (automake)aclocal Invocation. Generating aclocal.m4.
  37. # after: * aclocal-invocation v1.13: (automake-1.13)aclocal Invocation. Generating aclocal.m4.
  38. local p pages=( *.info ) args=()
  39. for p in "${pages[@]/%.info}" ; do
  40. args+=(
  41. -e "/START-INFO-DIR-ENTRY/,/END-INFO-DIR-ENTRY/s|: (${p})| v${SLOT}&|"
  42. -e "s:(${p}):(${p}-${SLOT}):g"
  43. )
  44. done
  45. sed -i "${args[@]}" * || die
  46. # Rewrite all the file references, and rename them in the process.
  47. local f d
  48. for f in * ; do
  49. d=${f/.info/-${SLOT}.info}
  50. mv "${f}" "${d}" || die
  51. sed -i -e "s:${f}:${d}:g" * || die
  52. done
  53. popd >/dev/null
  54. }
  55. src_install() {
  56. default
  57. slot_info_pages
  58. rm "${ED}"/usr/share/aclocal/README || die
  59. rmdir "${ED}"/usr/share/aclocal || die
  60. rm \
  61. "${ED}"/usr/bin/{aclocal,automake} \
  62. "${ED}"/usr/share/man/man1/{aclocal,automake}.1 || die
  63. # remove all config.guess and config.sub files replacing them
  64. # w/a symlink to a specific gnuconfig version
  65. local x
  66. for x in guess sub ; do
  67. dosym ../gnuconfig/config.${x} /usr/share/${PN}-${SLOT}/config.${x}
  68. done
  69. }