b43legacy-firmware-3.130.20.0.ebuild 753 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. : ${B43_FIRMWARE_SRC_OBJ:=${A}}
  5. MY_P="broadcom-wl-${PV}"
  6. DESCRIPTION="broadcom firmware for b43legacy/bcm43xx"
  7. HOMEPAGE="http://linuxwireless.org/en/users/Drivers/b43"
  8. SRC_URI="http://downloads.openwrt.org/sources/wl_apsta-${PV}.o"
  9. RESTRICT="mirror binchecks strip"
  10. LICENSE="Broadcom"
  11. SLOT=0
  12. KEYWORDS="~amd64 ~x86"
  13. IUSE=""
  14. RDEPEND=""
  15. DEPEND=">=net-wireless/b43-fwcutter-012"
  16. S=${WORKDIR}
  17. src_unpack() {
  18. cp "${DISTDIR}/${A}" "${WORKDIR}" || die
  19. }
  20. src_compile() {
  21. mkdir ebuild-output
  22. b43-fwcutter -w ebuild-output $(find -name ${B43_FIRMWARE_SRC_OBJ}) || die
  23. }
  24. src_install() {
  25. insinto /lib/firmware
  26. doins -r ebuild-output/*
  27. }