httrack-3.48.21-r1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
  6. HOMEPAGE="http://www.httrack.com/"
  7. SRC_URI="http://mirror.httrack.com/historical/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. IUSE="static-libs"
  12. RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
  13. dev-libs/openssl:="
  14. DEPEND="${RDEPEND}"
  15. DOCS=( AUTHORS README greetings.txt history.txt )
  16. src_prepare() {
  17. epatch "${FILESDIR}"/${PN}-3.48.13-minizip.patch
  18. }
  19. src_configure() {
  20. econf $(use_enable static-libs static) \
  21. --docdir=/usr/share/doc/${PF} \
  22. --htmldir=/usr/share/doc/${PF}/html
  23. }
  24. src_install() {
  25. default
  26. # Make webhttrack work despite FEATURES=nodoc cutting
  27. # all of /usr/share/doc/ away (bug #493376)
  28. if has nodoc ${FEATURES} ; then
  29. dodir /usr/share/${PF}/
  30. mv "${D}"/usr/share/{doc/,}${PF}/html || die
  31. rm "${D}"/usr/share/httrack/html || die
  32. dosym /usr/share/${PF}/html /usr/share/httrack/html
  33. fi
  34. find "${ED}" -type f -name '*.la' -delete || die
  35. }