httrack-3.48.22.ebuild 1.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils
  5. DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
  6. HOMEPAGE="http://www.httrack.com/"
  7. SRC_URI="http://mirror.httrack.com/historical/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
  11. IUSE="libressl static-libs"
  12. RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
  13. !libressl? ( dev-libs/openssl:= )
  14. libressl? ( dev-libs/libressl )
  15. "
  16. DEPEND="${RDEPEND}"
  17. DOCS=( AUTHORS README greetings.txt history.txt )
  18. src_prepare() {
  19. epatch "${FILESDIR}"/${PN}-3.48.13-minizip.patch
  20. }
  21. src_configure() {
  22. econf $(use_enable static-libs static) \
  23. --docdir="${EPREFIX}"/usr/share/doc/${PF} \
  24. --htmldir="${EPREFIX}"/usr/share/doc/${PF}/html
  25. }
  26. src_install() {
  27. default
  28. # Make webhttrack work despite FEATURES=nodoc cutting
  29. # all of /usr/share/doc/ away (bug #493376)
  30. if has nodoc ${FEATURES} ; then
  31. dodir /usr/share/${PF}/
  32. mv "${D}"/usr/share/{doc/,}${PF}/html || die
  33. rm "${D}"/usr/share/${PN}/html || die
  34. dosym /usr/share/${PF}/html /usr/share/${PN}/html
  35. fi
  36. find "${ED}" -type f -name '*.la' -delete || die
  37. }