mongoose-5.6.ebuild 679 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit toolchain-funcs
  5. DESCRIPTION="easy to use web server"
  6. SRC_URI="https://github.com/cesanta/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  7. HOMEPAGE="https://code.google.com/p/${PN}/"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~amd64-linux ~x86 ~arm-linux ~x86-linux"
  11. IUSE=""
  12. RDEPEND=""
  13. DEPEND=""
  14. S=${WORKDIR}/${P}/examples/web_server
  15. src_prepare() {
  16. eapply_user
  17. sed -e "s|-g -O0 ||" -i Makefile || die
  18. }
  19. src_compile() {
  20. tc-export CC
  21. emake CFLAGS_EXTRA="${CFLAGS}" web_server
  22. }
  23. src_install() {
  24. newbin "${S}/web_server" "${PN}"
  25. dodoc ../../README.md
  26. }