pound-2.6.ebuild 1.3 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit eutils
  5. MY_P=${P/p/P}
  6. DESCRIPTION="A http/https reverse-proxy and load-balancer"
  7. HOMEPAGE="http://www.apsis.ch/pound/"
  8. SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
  9. LICENSE="GPL-3"
  10. SLOT="0"
  11. KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc x86"
  12. IUSE="dynscaler"
  13. DEPEND="dev-libs/libpcre
  14. dev-libs/openssl"
  15. RDEPEND="${DEPEND}"
  16. S=${WORKDIR}/${MY_P}
  17. src_configure() {
  18. econf \
  19. $(use_enable dynscaler)
  20. }
  21. src_install() {
  22. dodir /usr/sbin
  23. cp "${S}"/pound "${D}"/usr/sbin/
  24. cp "${S}"/poundctl "${D}"/usr/sbin/
  25. doman pound.8
  26. doman poundctl.8
  27. dodoc README FAQ
  28. dodir /etc/init.d
  29. newinitd "${FILESDIR}"/pound.init-1.9 pound
  30. insinto /etc
  31. newins "${FILESDIR}"/pound-2.2.cfg pound.cfg
  32. }
  33. pkg_postinst() {
  34. elog "No demo-/sample-configfile is included in the distribution -"
  35. elog "read the man-page for more info."
  36. elog "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
  37. echo
  38. ewarn "You will have to upgrade you configuration file, if you are"
  39. ewarn "upgrading from a version <= 2.0."
  40. echo
  41. ewarn "The 'WebDAV' config statement is no longer supported!"
  42. ewarn "Please adjust your configuration, if necessary."
  43. echo
  44. }