spawn-fcgi-1.6.3-r1.ebuild 784 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. DESCRIPTION="A FCGI spawner for lighttpd and cherokee and other webservers"
  5. HOMEPAGE="http://redmine.lighttpd.net/projects/spawn-fcgi"
  6. SRC_URI="http://www.lighttpd.net/download/${P}.tar.bz2"
  7. LICENSE="BSD GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
  10. IUSE="ipv6"
  11. DEPEND=""
  12. RDEPEND="!<=www-servers/lighttpd-1.4.20
  13. !<=www-servers/cherokee-0.98.1"
  14. src_configure() {
  15. econf $(use_enable ipv6)
  16. }
  17. src_install() {
  18. emake DESTDIR="${D}" install
  19. dodoc README NEWS
  20. newconfd "${FILESDIR}"/spawn-fcgi.confd spawn-fcgi
  21. newinitd "${FILESDIR}"/spawn-fcgi.initd-r1 spawn-fcgi
  22. docinto examples
  23. dodoc doc/run-generic doc/run-php doc/run-rails
  24. }