spawn-fcgi-1.6.4.ebuild 755 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. DESCRIPTION="A FCGI spawner for lighttpd and cherokee and other webservers"
  5. HOMEPAGE="http://redmine.lighttpd.net/projects/spawn-fcgi"
  6. SRC_URI="http://www.lighttpd.net/download/${P}.tar.xz"
  7. LICENSE="BSD GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
  10. IUSE="ipv6"
  11. DEPEND=""
  12. RDEPEND="
  13. !<=www-servers/lighttpd-1.4.20
  14. !<=www-servers/cherokee-0.98.1"
  15. src_configure() {
  16. econf $(use_enable ipv6)
  17. }
  18. src_install() {
  19. default
  20. newconfd "${FILESDIR}"/spawn-fcgi.confd spawn-fcgi
  21. newinitd "${FILESDIR}"/spawn-fcgi.initd-r2 spawn-fcgi
  22. docinto examples
  23. dodoc doc/run-generic doc/run-php doc/run-rails
  24. }