grun-0.9.3-r1.ebuild 845 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="A GTK based Run dialog resembling the Windows Run dialog, just like xexec"
  6. HOMEPAGE="https://github.com/lrgc/grun"
  7. SRC_URI="https://grun.googlecode.com/files/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ppc x86 ~x86-fbsd"
  11. IUSE="nls"
  12. RDEPEND="
  13. dev-libs/glib:2
  14. x11-libs/gdk-pixbuf
  15. x11-libs/gtk+:2
  16. "
  17. DEPEND="
  18. ${RDEPEND}
  19. virtual/pkgconfig
  20. nls? ( sys-devel/gettext )
  21. "
  22. src_prepare() {
  23. epatch "${FILESDIR}"/${P}-no_nls.patch
  24. }
  25. src_configure() {
  26. [[ -z ${TERM} ]] && TERM=xterm
  27. econf \
  28. $(use_enable nls) \
  29. --disable-gtktest \
  30. --enable-associations \
  31. --enable-testfile \
  32. --with-default-xterm=${TERM}
  33. }
  34. src_install() {
  35. default
  36. dodoc AUTHORS BUGS ChangeLog NEWS README TODO
  37. }