ipager-1.1.0.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=2
  4. inherit eutils
  5. DESCRIPTION="A themable desktop pager for fluxbox and other window managers"
  6. HOMEPAGE="http://www.useperl.ru/ipager/index.en.html"
  7. SRC_URI="http://www.useperl.ru/ipager/src/${P}.tar.gz"
  8. LICENSE="MIT"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="xinerama"
  12. RDEPEND="media-libs/imlib2[X]
  13. x11-libs/libXmu
  14. xinerama? ( x11-libs/libXinerama )"
  15. DEPEND="${RDEPEND}
  16. dev-util/scons"
  17. src_prepare() {
  18. epatch "${FILESDIR}"/${P}-scons_imlib2.patch
  19. epatch "${FILESDIR}"/${P}-scons_flags.patch
  20. epatch "${FILESDIR}"/${P}-gcc43.patch
  21. epatch "${FILESDIR}"/${P}-gcc47.patch
  22. }
  23. src_compile() {
  24. CONFIG_OPTS="xinerama=false"
  25. use xinerama && CONFIG_OPTS="${CONFIG_OPTS} xinerama=true"
  26. # FYI: Passing debug=true only adds -ggdb inside the SConstruct
  27. scons \
  28. --cache-disable \
  29. PREFIX="/usr" \
  30. ${CONFIG_OPTS} \
  31. || die "scons configure failed"
  32. }
  33. src_install() {
  34. scons \
  35. --cache-disable \
  36. PREFIX="/usr" \
  37. DESTDIR="${D}" \
  38. install \
  39. || die "scons install failed"
  40. dodoc ToDo ChangeLog README
  41. dodoc themes/*.conf
  42. }