kapow-1.5.2.ebuild 624 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit qmake-utils
  5. DESCRIPTION="A punch clock program designed to easily keep track of your hours"
  6. HOMEPAGE="http://gottcode.org/kapow/"
  7. SRC_URI="http://gottcode.org/${PN}/${P}-src.tar.bz2"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. DEPEND="
  12. dev-qt/qtcore:5
  13. dev-qt/qtgui:5
  14. dev-qt/qtnetwork:5
  15. dev-qt/qtprintsupport:5
  16. dev-qt/qtwidgets:5
  17. "
  18. RDEPEND="
  19. ${DEPEND}
  20. "
  21. DOCS=( ChangeLog README )
  22. src_configure() {
  23. eqmake5 kapow.pro PREFIX=/usr
  24. }
  25. src_install() {
  26. export INSTALL_ROOT="${D}"
  27. default
  28. }