notification-daemon-3.20.0.ebuild 971 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit gnome.org
  5. DESCRIPTION="Notification daemon"
  6. HOMEPAGE="https://git.gnome.org/browse/notification-daemon/"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
  10. IUSE=""
  11. RDEPEND="
  12. >=dev-libs/glib-2.28:2
  13. >=x11-libs/gtk+-3.19.5:3[X]
  14. sys-apps/dbus
  15. x11-libs/libX11
  16. !x11-misc/notify-osd
  17. !x11-misc/qtnotifydaemon
  18. "
  19. DEPEND="${RDEPEND}
  20. dev-util/gdbus-codegen
  21. >=sys-devel/gettext-0.19.4
  22. virtual/pkgconfig
  23. "
  24. DOCS=( AUTHORS ChangeLog NEWS )
  25. src_install() {
  26. default
  27. cat <<-EOF > "${T}"/org.freedesktop.Notifications.service
  28. [D-BUS Service]
  29. Name=org.freedesktop.Notifications
  30. Exec=/usr/libexec/notification-daemon
  31. EOF
  32. insinto /usr/share/dbus-1/services
  33. doins "${T}"/org.freedesktop.Notifications.service
  34. }