xdg-user-dirs-gtk-0.10.ebuild 971 B

12345678910111213141516171819202122232425262728293031323334353637
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit gnome.org readme.gentoo
  5. DESCRIPTION="Integrates xdg-user-dirs into the Gnome desktop and Gtk+ applications"
  6. HOMEPAGE="https://www.freedesktop.org/wiki/Software/xdg-user-dirs"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  10. IUSE=""
  11. RDEPEND="
  12. >=x11-misc/xdg-user-dirs-0.14
  13. >=x11-libs/gtk+-3.5.1:3
  14. "
  15. DEPEND="${RDEPEND}
  16. dev-util/intltool
  17. virtual/pkgconfig
  18. "
  19. DOC_CONTENTS="
  20. This package tries to automatically use some sensible default
  21. directories for your documents, music, video and other stuff.
  22. If you want to change those directories to your needs, see
  23. the settings in ~/.config/user-dirs.dirs
  24. "
  25. src_prepare() {
  26. sed -i \
  27. -e '/Encoding/d' \
  28. -e 's:OnlyShowIn=GNOME;LXDE;Unity;:NotShowIn=KDE;:' \
  29. user-dirs-update-gtk.desktop.in || die
  30. }