xnee-3.19-r1.ebuild 1.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Program suite to record, replay and distribute user actions"
  6. HOMEPAGE="http://www.sandklef.com/xnee/"
  7. SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~x86"
  11. IUSE="gnome static-libs xosd"
  12. RDEPEND="
  13. x11-libs/libX11
  14. x11-libs/libXau
  15. x11-libs/libXdmcp
  16. x11-libs/libXext
  17. x11-libs/libXi
  18. x11-libs/libXtst
  19. x11-libs/libxcb
  20. gnome? (
  21. x11-libs/gtk+:2
  22. >=gnome-base/libgnomeui-2
  23. >=gnome-base/gconf-2
  24. )
  25. "
  26. DEPEND="${RDEPEND}
  27. x11-proto/inputproto
  28. virtual/pkgconfig
  29. sys-devel/gettext
  30. gnome? ( virtual/imagemagick-tools[jpeg,png] )
  31. "
  32. # This needs RECORD extension from X.org server which isn't necessarily
  33. # enabled. Xlib: extension "RECORD" missing on display ":0.0".
  34. RESTRICT="test"
  35. src_prepare() {
  36. epatch "${FILESDIR}"/${PN}-3.18-linker.patch
  37. eautoreconf
  38. }
  39. src_configure() {
  40. econf \
  41. $(use_enable gnome gui) \
  42. $(use_enable static-libs static) \
  43. $(use_enable xosd buffer_verbose) \
  44. $(use_enable xosd verbose) \
  45. $(use_enable xosd) \
  46. --disable-gnome-applet \
  47. --disable-static-programs \
  48. --enable-cli \
  49. --enable-lib
  50. }
  51. src_test() {
  52. Xemake check
  53. }
  54. src_install() {
  55. default
  56. dodoc AUTHORS BUGS ChangeLog FAQ NEWS README TODO
  57. use gnome && make_desktop_entry gnee Gnee ${PN} "Utility;GTK"
  58. use static-libs || rm -f "${ED}"usr/lib*/lib*.la
  59. }