eterm-0.9.6.ebuild 1.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="3"
  4. inherit eutils autotools
  5. MY_P=Eterm-${PV}
  6. if [[ ${PV} == "9999" ]] ; then
  7. ESVN_REPO_URI="https://svn.enlightenment.org/svn/e/trunk/eterm/Eterm"
  8. inherit subversion
  9. SRC_URI=""
  10. KEYWORDS=""
  11. else
  12. SRC_URI="http://www.eterm.org/download/${MY_P}.tar.gz
  13. !minimal? ( http://www.eterm.org/download/Eterm-bg-${PV}.tar.gz )"
  14. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x86-macos"
  15. fi
  16. DESCRIPTION="A vt102 terminal emulator for X"
  17. HOMEPAGE="http://www.eterm.org/"
  18. LICENSE="BSD"
  19. SLOT="0"
  20. IUSE="escreen minimal cpu_flags_x86_mmx cpu_flags_x86_sse2 unicode +utempter"
  21. RDEPEND="x11-libs/libX11
  22. x11-libs/libXmu
  23. x11-libs/libXt
  24. x11-libs/libICE
  25. x11-libs/libSM
  26. x11-proto/xextproto
  27. x11-proto/xproto
  28. >=x11-libs/libast-0.6.1
  29. media-libs/imlib2[X]
  30. media-fonts/font-misc-misc
  31. escreen? ( app-misc/screen )"
  32. DEPEND="${RDEPEND}"
  33. if [[ ${PV} == "9999" ]] ; then
  34. S=${WORKDIR}/${ECVS_MODULE}
  35. else
  36. S=${WORKDIR}/${MY_P}
  37. fi
  38. src_unpack() {
  39. if [[ ${PV} == "9999" ]] ; then
  40. subversion_src_unpack
  41. cd "${S}"
  42. eautoreconf
  43. else
  44. unpack ${MY_P}.tar.gz
  45. cd "${S}"
  46. use minimal || unpack Eterm-bg-${PV}.tar.gz
  47. fi
  48. }
  49. src_prepare() {
  50. epatch "${FILESDIR}"/${P}-asm-gnu-stack.patch #440618
  51. }
  52. src_configure() {
  53. export TIC="true"
  54. econf \
  55. --disable-static \
  56. $(use_enable escreen) \
  57. --with-imlib \
  58. --enable-trans \
  59. $(use_enable cpu_flags_x86_mmx mmx) \
  60. $(use_enable cpu_flags_x86_sse2 sse2) \
  61. $(use_enable unicode multi-charset) \
  62. $(use_enable utempter utmp) \
  63. --with-delete=execute \
  64. --with-backspace=auto
  65. }
  66. src_install() {
  67. emake DESTDIR="${D}" install || die
  68. dodoc ChangeLog README ReleaseNotes
  69. use escreen && dodoc doc/README.Escreen
  70. dodoc bg/README.backgrounds
  71. # We don't install headers to link against this library
  72. rm -f "${D}"/usr/*/libEterm.{so,la}
  73. }