exo-0.10.6.ebuild 1.0 KB

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="Extensions, widgets and framework library with session support for the Xfce desktop environment"
  6. HOMEPAGE="http://www.xfce.org/projects/"
  7. SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2 LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
  11. IUSE="debug"
  12. RDEPEND=">=dev-lang/perl-5.6
  13. >=dev-libs/glib-2.30:=
  14. dev-perl/URI
  15. >=x11-libs/gtk+-2.24:2=
  16. >=xfce-base/libxfce4ui-4.10:=
  17. >=xfce-base/libxfce4util-4.10:="
  18. DEPEND="${RDEPEND}
  19. dev-util/intltool
  20. sys-devel/gettext
  21. virtual/pkgconfig"
  22. pkg_setup() {
  23. XFCONF=(
  24. --docdir="${EPREFIX}"/usr/share/doc/${PF}
  25. $(xfconf_use_debug)
  26. --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
  27. )
  28. [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
  29. DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
  30. }