exo-0.11.2.ebuild 1.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
  6. HOMEPAGE="http://www.xfce.org/projects/"
  7. SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2 LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
  11. IUSE="debug"
  12. RDEPEND=">=dev-lang/perl-5.6
  13. >=dev-libs/glib-2.30:=
  14. dev-perl/URI
  15. >=x11-libs/gtk+-2.24:2=
  16. >=x11-libs/gtk+-3.6.0:3=
  17. >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
  18. >=xfce-base/libxfce4util-4.10:="
  19. DEPEND="${RDEPEND}
  20. dev-util/gtk-doc-am
  21. dev-util/intltool
  22. sys-devel/gettext
  23. virtual/pkgconfig"
  24. pkg_setup() {
  25. XFCONF=(
  26. --docdir="${EPREFIX}"/usr/share/doc/${PF}
  27. $(xfconf_use_debug)
  28. # both required for GTK+3 support
  29. # (non-GTK+3 variant fails to build, as predicted)
  30. --enable-gtk3
  31. --enable-libxfce4ui2
  32. )
  33. [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
  34. DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
  35. }