12345678910111213141516171819202122232425262728293031323334353637383940414243 |
- # Copyright 1999-2017 Gentoo Foundation
- # Distributed under the terms of the GNU General Public License v2
- EAPI=5
- inherit xfconf
- DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
- HOMEPAGE="http://www.xfce.org/projects/"
- SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
- LICENSE="GPL-2 LGPL-2.1"
- SLOT="0"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
- IUSE="debug"
- RDEPEND=">=dev-lang/perl-5.6
- >=dev-libs/glib-2.30:=
- dev-perl/URI
- >=x11-libs/gtk+-2.24:2=
- >=x11-libs/gtk+-3.6.0:3=
- >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
- >=xfce-base/libxfce4util-4.10:="
- DEPEND="${RDEPEND}
- dev-util/gtk-doc-am
- dev-util/intltool
- sys-devel/gettext
- virtual/pkgconfig"
- pkg_setup() {
- XFCONF=(
- --docdir="${EPREFIX}"/usr/share/doc/${PF}
- $(xfconf_use_debug)
- # both required for GTK+3 support
- # (non-GTK+3 variant fails to build, as predicted)
- --enable-gtk3
- --enable-libxfce4ui2
- )
- [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
- DOCS=( AUTHORS ChangeLog HACKING NEWS README THANKS TODO )
- }
|