xfce4-appfinder-4.12.0-r1.ebuild 884 B

123456789101112131415161718192021222324252627282930313233343536
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit xfconf
  5. DESCRIPTION="A tool to find and launch installed applications for the Xfce desktop environment"
  6. HOMEPAGE="http://www.xfce.org/projects/"
  7. SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~mips ppc ppc64 sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x86-solaris"
  11. IUSE="debug"
  12. RDEPEND=">=dev-libs/glib-2.30:=
  13. >=x11-libs/gtk+-3.2:3=
  14. >=xfce-base/garcon-0.3:=
  15. >=xfce-base/libxfce4util-4.11:=
  16. >=xfce-base/libxfce4ui-4.11:=[gtk3(+)]
  17. >=xfce-base/xfconf-4.10:=
  18. !xfce-base/xfce-utils"
  19. DEPEND="${RDEPEND}
  20. dev-util/intltool
  21. sys-devel/gettext
  22. virtual/pkgconfig"
  23. pkg_setup() {
  24. XFCONF=(
  25. --enable-gtk3
  26. $(xfconf_use_debug)
  27. )
  28. DOCS=( AUTHORS ChangeLog NEWS )
  29. }