ccze-0.2.1-r4.ebuild 942 B

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit fixheadtails autotools eutils toolchain-funcs
  5. DESCRIPTION="A flexible and fast logfile colorizer"
  6. HOMEPAGE="https://dev.gentoo.org/~joker/ccze/ccze.txt"
  7. SRC_URI="mirror://gentoo/${P}.tar.gz"
  8. RESTRICT="test"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~arm ~ppc ~x86 ~x86-fbsd"
  12. IUSE=""
  13. DEPEND="dev-libs/libpcre
  14. sys-libs/ncurses:0="
  15. RDEPEND="${DEPEND}"
  16. DOCS=( AUTHORS ChangeLog ChangeLog-0.1 NEWS THANKS README FAQ )
  17. PATCHES=(
  18. "${FILESDIR}"/ccze-fbsd.patch
  19. "${FILESDIR}"/ccze-segfault.patch
  20. "${FILESDIR}"/ccze-ldflags.patch
  21. "${FILESDIR}"/${P}-tinfo.patch
  22. )
  23. src_prepare() {
  24. default
  25. # GCC 4.x fixes
  26. sed -e 's/-Wswitch -Wmulticharacter/-Wswitch/' \
  27. -i src/Makefile.in || die
  28. sed -e '/AC_CHECK_TYPE(error_t, int)/d' \
  29. -i configure.ac || die
  30. eautoreconf
  31. ht_fix_file Rules.mk.in
  32. tc-export CC
  33. }