lsat-0.9.7.1-r1.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748
  1. # Copyright 1999-2012 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit eutils toolchain-funcs
  4. DESCRIPTION="The Linux Security Auditing Tool"
  5. HOMEPAGE="http://usat.sourceforge.net/"
  6. SRC_URI="http://usat.sourceforge.net/code/${P}.tgz"
  7. LICENSE="GPL-2"
  8. SLOT="0"
  9. KEYWORDS="amd64 ppc x86"
  10. IUSE="minimal"
  11. DEPEND="dev-lang/perl" # pod2man
  12. RDEPEND="!minimal? (
  13. app-portage/portage-utils
  14. net-analyzer/nmap
  15. sys-apps/iproute2
  16. sys-apps/which
  17. sys-process/lsof
  18. )"
  19. src_unpack() {
  20. unpack ${A}
  21. cd "${S}"
  22. epatch "${FILESDIR}"/${P}-gentoo.patch
  23. # patch for segmentation fault see bug #184488
  24. epatch "${FILESDIR}"/${P}-segfault-fix.patch
  25. sed -i Makefile.in \
  26. -e '/^LDFLAGS=/d' \
  27. -e '/^CFLAGS=/d' \
  28. || die "sed Makefile.in"
  29. }
  30. src_compile() {
  31. tc-export CC
  32. econf
  33. emake CFLAGS="${CFLAGS}" all manpage || die "emake failed"
  34. }
  35. src_install() {
  36. emake DESTDIR="${D}" install installman || die "emake install failed"
  37. dodoc README* *.txt
  38. dohtml modules.html changelog/changelog.html
  39. }