unar-1.10.1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="unpacker for various archiving formats, e.g. rar v3"
  6. HOMEPAGE="https://unarchiver.c3.cx/"
  7. SRC_URI="https://unarchiver.c3.cx/downloads/${PN}${PV}_src.zip"
  8. LICENSE="LGPL-2.1"
  9. SLOT="0"
  10. KEYWORDS="amd64"
  11. IUSE=""
  12. RDEPEND="gnustep-base/gnustep-base
  13. dev-libs/icu:=
  14. sys-libs/zlib
  15. app-arch/bzip2"
  16. DEPEND="${RDEPEND}
  17. >=gnustep-base/gnustep-make-2.6.0[native-exceptions]
  18. sys-devel/gcc[objc]"
  19. S="${WORKDIR}/The Unarchiver/XADMaster"
  20. src_prepare() {
  21. # avoid jobserver warning, upstream bug:
  22. # https://bitbucket.org/WAHa_06x36/theunarchiver/issues/918/dont-call-make-from-makefile
  23. sed -i -e 's:make:$(MAKE):g' Makefile.linux
  24. }
  25. src_compile() {
  26. emake -f Makefile.linux \
  27. AR="$(tc-getAR)" \
  28. CC="$(tc-getCC)" \
  29. CXX="$(tc-getCXX)" \
  30. OBJCC="$(tc-getCC)" \
  31. CFLAGS="${CFLAGS}" \
  32. CXXFLAGS="${CXXFLAGS}" \
  33. OBJCFLAGS="${CFLAGS}" \
  34. LD="$(tc-getCXX)" \
  35. LDFLAGS="-Wl,--whole-archive -fexceptions -fgnu-runtime ${LDFLAGS}"
  36. }
  37. src_install() {
  38. dobin {ls,un}ar
  39. doman ../Extra/{ls,un}ar.1
  40. }