backintime-1.1.12.ebuild 1.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. PYTHON_COMPAT=( python3_{4,5} )
  5. inherit eutils python-single-r1
  6. DESCRIPTION="Backup system inspired by TimeVault and FlyBack, with a GUI for GNOME and KDE4"
  7. HOMEPAGE="http://backintime.le-web.org/"
  8. SRC_URI="http://${PN}.le-web.org/download/${PN}/${P}.tar.gz"
  9. LICENSE="GPL-2"
  10. SLOT="0"
  11. KEYWORDS="amd64 x86"
  12. IUSE="qt4"
  13. DEPEND="${PYTHON_DEPS}
  14. dev-python/dbus-python[${PYTHON_USEDEP}]
  15. dev-python/keyring[${PYTHON_USEDEP}]
  16. net-misc/openssh
  17. net-misc/rsync[xattr,acl]"
  18. RDEPEND="${DEPEND}
  19. qt4? ( dev-python/PyQt4 )"
  20. REQUIRED_USE="${PYTHON_REQUIRED_USE}"
  21. src_prepare() {
  22. #fix doc install location
  23. sed -e "s:/doc/${PN}-common:/doc/${PF}:g" \
  24. -i common/configure || die
  25. sed -e "s:/doc/${PN}-qt4:/doc/${PF}:g" \
  26. -i qt4/configure || die
  27. sed -e "/addInstallFile \"..\/VERSION/d" \
  28. -e "/addInstallFile \"..\/LICENSE/d" \
  29. -e "/addInstallFile \"..\/debian\/copyright/d" \
  30. -i {qt4,common}/configure || die
  31. if [ -n ${LINGUAS+x} ] ; then
  32. cd common/po || die
  33. for po in *.po ; do
  34. if ! has ${po/.po} ${LINGUAS} ; then
  35. rm ${po} || die
  36. fi
  37. done
  38. fi
  39. }
  40. src_configure() {
  41. cd "${S}"/common || die
  42. ./configure --python3 --no-fuse-group || die
  43. if use qt4 ; then
  44. cd "${S}"/qt4 || die
  45. ./configure --python3 || die
  46. fi
  47. }
  48. src_compile() {
  49. cd "${S}"/common || die
  50. emake
  51. if use qt4 ; then
  52. cd "${S}"/qt4 || die
  53. emake
  54. fi
  55. }
  56. src_install() {
  57. cd "${S}"/common || die
  58. emake DESTDIR="${D}" install
  59. if use qt4 ; then
  60. cd "${S}"/qt4 || die
  61. emake DESTDIR="${D}" install
  62. fi
  63. python_optimize "${D}"
  64. }