tarsnap-1.0.37.ebuild 927 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit bash-completion-r1
  5. DESCRIPTION="Online backups for the truly paranoid"
  6. HOMEPAGE="http://www.tarsnap.com/"
  7. SRC_URI="https://www.tarsnap.com/download/${PN}-autoconf-${PV}.tgz"
  8. LICENSE="tarsnap"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~x86"
  11. IUSE="acl bzip2 libressl lzma xattr"
  12. RDEPEND="
  13. !libressl? ( dev-libs/openssl:0= )
  14. libressl? ( dev-libs/libressl:0= )
  15. sys-libs/e2fsprogs-libs
  16. sys-libs/zlib
  17. acl? ( sys-apps/acl )
  18. bzip2? ( app-arch/bzip2 )
  19. lzma? ( app-arch/xz-utils )
  20. xattr? ( sys-apps/attr )"
  21. DEPEND="${RDEPEND}
  22. virtual/os-headers" # Required for "magic.h"
  23. S=${WORKDIR}/${PN}-autoconf-${PV}
  24. src_configure() {
  25. econf \
  26. $(use_enable xattr) \
  27. $(use_enable acl) \
  28. $(use_with bzip2 bz2lib) \
  29. --without-lzmadec \
  30. $(use_with lzma)
  31. }
  32. src_install() {
  33. default
  34. dobashcomp misc/bash_completion.d/*
  35. }