podbrowser-0.12-r3.ebuild 1011 B

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit eutils
  5. DESCRIPTION="PodBrowser is a documentation browser for Perl"
  6. HOMEPAGE="http://jodrell.net/projects/podbrowser"
  7. SRC_URI="http://jodrell.net/files/podbrowser/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="amd64 ~x86"
  11. IUSE=""
  12. SRC_TEST="do"
  13. RDEPEND="dev-perl/gtk2-gladexml
  14. dev-perl/Gtk2
  15. dev-perl/HTML-Parser
  16. dev-perl/Locale-gettext
  17. virtual/perl-Pod-Simple
  18. dev-perl/URI
  19. dev-perl/Gtk2-Ex-PodViewer
  20. dev-perl/Gtk2-Ex-PrintDialog
  21. dev-perl/Gtk2-Ex-Simple-List
  22. || ( >=dev-lang/perl-5.16 <dev-lang/perl-5.16[-build] )
  23. >=x11-libs/gtk+-2.6.0:2
  24. >=x11-themes/gnome-icon-theme-2.10.0
  25. >=gnome-base/libglade-2:2.0"
  26. DEPEND="${RDEPEND}
  27. sys-devel/gettext"
  28. src_prepare() {
  29. epatch "${FILESDIR}"/missing_icon.patch
  30. cp "${FILESDIR}"/Makefile.new "${S}"/Makefile || die
  31. }
  32. src_compile() {
  33. emake DESTDIR="${D}" PREFIX=/usr
  34. }
  35. src_install() {
  36. emake PREFIX=/usr DESTDIR="${D}" install
  37. }