shed-1.15.ebuild 574 B

12345678910111213141516171819202122232425262728
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit autotools eutils
  5. DESCRIPTION="Simple Hex EDitor"
  6. HOMEPAGE="http://shed.sourceforge.net/"
  7. SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
  8. LICENSE="GPL-2"
  9. SLOT="0"
  10. KEYWORDS="~amd64 ~arm ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
  11. RDEPEND="sys-libs/ncurses"
  12. DEPEND="
  13. ${RDEPEND}
  14. virtual/pkgconfig
  15. "
  16. src_prepare() {
  17. epatch \
  18. "${FILESDIR}"/${P}-cflags.patch \
  19. "${FILESDIR}"/${P}-interix.patch \
  20. "${FILESDIR}"/${P}-tinfo.patch
  21. eautoreconf
  22. }