lynis-1.6.4.ebuild 969 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455
  1. # Copyright 1999-2015 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. inherit eutils bash-completion-r1
  5. DESCRIPTION="Security and system auditing tool"
  6. HOMEPAGE="http://cisofy.com/lynis/"
  7. SRC_URI="http://cisofy.com/files/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="amd64 x86"
  11. IUSE=""
  12. DEPEND=""
  13. RDEPEND="app-shells/bash"
  14. S="${WORKDIR}/${PN}"
  15. src_prepare() {
  16. # Bug 507438
  17. epatch_user
  18. }
  19. src_install() {
  20. doman lynis.8
  21. dodoc CHANGELOG FAQ README
  22. # Remove the old one during the next stabilize progress
  23. exeinto /etc/cron.daily
  24. newexe "${FILESDIR}"/lynis.cron-new lynis
  25. dobashcomp extras/bash_completion.d/lynis
  26. # stricter default perms - bug 507436
  27. diropts -m0700
  28. insopts -m0600
  29. insinto /usr/share/${PN}
  30. doins -r db/ include/ plugins/
  31. dosbin lynis
  32. insinto /etc/${PN}
  33. doins default.prf
  34. }
  35. pkg_postinst() {
  36. einfo
  37. einfo "A cron script has been installed to ${ROOT}etc/cron.daily/lynis."
  38. einfo
  39. }