zzuf-0.13-r1.ebuild 1.1 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit autotools eutils
  5. DESCRIPTION="Transparent application input fuzzer"
  6. HOMEPAGE="http://caca.zoy.org/wiki/zzuf"
  7. SRC_URI="http://caca.zoy.org/files/${PN}/${P}.tar.gz
  8. https://dev.gentoo.org/~cardoe/distfiles/${P}-zzcat-zzat-rename.patch.bz2"
  9. LICENSE="WTFPL-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~sparc ~x86"
  12. IUSE=""
  13. # fails with sandbox enabled
  14. RESTRICT="test"
  15. DOCS=( AUTHORS ChangeLog NEWS README TODO )
  16. src_prepare() {
  17. sed -i -e '/CFLAGS/d' "${S}"/configure.ac \
  18. || die "unable to fix the configure.ac"
  19. sed -i -e 's:noinst_:check_:' "${S}"/test/Makefile.am \
  20. || die "unable to fix unconditional test building"
  21. epatch "${DISTDIR}"/${P}-zzcat-zzat-rename.patch.bz2
  22. eautoreconf
  23. }
  24. src_configure() {
  25. # Don't build the static library, as the library is only used for
  26. # preloading, so there is no reason to build it statically, unless
  27. # you want to use zzuf with a static-linked executable, which I'm
  28. # not even sure would be a good idea.
  29. econf --disable-static
  30. }
  31. src_install() {
  32. default
  33. find "${D}" -name '*.la' -delete
  34. }