agrep-2.04.ebuild 786 B

123456789101112131415161718192021222324252627282930313233
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. inherit toolchain-funcs
  4. DESCRIPTION="A tool for the fast searching of text allowing for errors in the search pattern"
  5. HOMEPAGE="ftp://ftp.cs.arizona.edu/agrep/README"
  6. SRC_URI="ftp://ftp.cs.arizona.edu/agrep/${P}.tar.Z"
  7. LICENSE="AGREP"
  8. SLOT="0"
  9. KEYWORDS="amd64 ~mips ppc ppc64 sparc x86 ~ppc-macos ~sparc-solaris"
  10. IUSE=""
  11. DEPEND=""
  12. RDEPEND="
  13. !dev-libs/tre
  14. !app-misc/glimpse"
  15. src_compile() {
  16. # Remove first occurace of CFLAGS so we grab the user CFLAGS
  17. sed -i -e 's/^CFLAGS.*//' Makefile || die
  18. tc-export CC
  19. emake || die
  20. }
  21. src_install() {
  22. dobin agrep || die
  23. doman agrep.1 || die
  24. dodoc README agrep.algorithms agrep.chronicle COPYRIGHT \
  25. contribution.list || die
  26. }