dvibook-20001129.ebuild 731 B

1234567891011121314151617181920212223242526272829303132333435363738
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="6"
  4. inherit toolchain-funcs
  5. DESCRIPTION="DVI file utilities: dvibook, dviconcat, dvitodvi, and dviselect"
  6. HOMEPAGE="http://www.ctan.org/tex-archive/dviware/dvibook/"
  7. # Taken from: ftp://tug.ctan.org/tex-archive/dviware/${PN}.tar.gz
  8. SRC_URI="mirror://gentoo/${P}.tar.gz"
  9. LICENSE="dvibook"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc x86"
  12. IUSE=""
  13. DEPEND="x11-misc/imake
  14. x11-misc/gccmakedep
  15. app-text/rman"
  16. RDEPEND=""
  17. S="${WORKDIR}/${PN}"
  18. PATCHES=(
  19. "${FILESDIR}/${P}.patch"
  20. )
  21. src_compile() {
  22. xmkmf -a || die "xmkmf failed"
  23. emake CC="$(tc-getCC)"
  24. }
  25. src_install() {
  26. emake DESTDIR="${D}" install install.man
  27. dodoc README
  28. }