dvisvgm-2.1.1.ebuild 1.1 KB

123456789101112131415161718192021222324252627282930313233343536373839
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs flag-o-matic
  5. DESCRIPTION="Converts DVI files to SVG"
  6. HOMEPAGE="http://dvisvgm.bplaced.net/"
  7. SRC_URI="https://github.com/mgieseki/dvisvgm/releases/download/${PV}/${P}.tar.gz"
  8. LICENSE="GPL-3"
  9. SLOT="0"
  10. KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ppc-macos ~x64-macos ~x86-macos"
  11. IUSE="test"
  12. # Tests don't work from $WORKDIR: kpathsea tries to search in relative
  13. # directories from where the binary is executed.
  14. # We cannot really use absolute paths in the kpathsea configuration since that
  15. # would make it harder for prefix installs.
  16. RESTRICT="test"
  17. RDEPEND="virtual/tex-base
  18. app-text/ghostscript-gpl
  19. >=media-gfx/potrace-1.10-r1
  20. media-libs/freetype:2
  21. dev-libs/kpathsea
  22. sys-libs/zlib"
  23. DEPEND="${RDEPEND}
  24. app-text/xmlto
  25. app-text/asciidoc
  26. dev-libs/libxslt
  27. virtual/pkgconfig
  28. test? ( dev-cpp/gtest )"
  29. src_configure() {
  30. has_version '>=dev-libs/kpathsea-6.2.1' && append-cppflags "$($(tc-getPKG_CONFIG) --cflags kpathsea)"
  31. default
  32. }