psiconv-0.8.3-r1.ebuild 579 B

1234567891011121314151617181920212223242526272829
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=5
  4. inherit toolchain-funcs
  5. DESCRIPTION="An interpreter for Psion 5(MX) file formats"
  6. HOMEPAGE="http://huizen.dds.nl/~frodol/psiconv"
  7. SRC_URI="http://huizen.dds.nl/~frodol/${PN}/${P}.tar.gz"
  8. SLOT="0"
  9. LICENSE="GPL-2"
  10. IUSE="static-libs"
  11. KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
  12. src_prepare() {
  13. tc-export AR
  14. }
  15. src_configure() {
  16. econf $(use_enable static-libs static)
  17. }
  18. src_install() {
  19. default
  20. use static-libs || rm -fr "${D}"usr/lib*/lib${PN}.la
  21. }