rfcutil-3.2.3-r2.ebuild 951 B

12345678910111213141516171819202122232425262728293031323334353637383940414243444546
  1. # Copyright 1999-2013 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=4
  4. inherit eutils prefix
  5. MY_PN="rfc"
  6. MY_P="${MY_PN}-${PV}"
  7. S="${WORKDIR}/${MY_P}"
  8. DESCRIPTION="return all related RFCs based upon a number or a search string"
  9. HOMEPAGE="http://www.dewn.com/rfc/"
  10. SRC_URI="http://www.dewn.com/rfc/${MY_P}.tar.gz"
  11. LICENSE="freedist"
  12. SLOT="0"
  13. KEYWORDS="amd64 ~mips ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
  14. IUSE=""
  15. RDEPEND="dev-lang/perl
  16. || ( www-client/lynx virtual/w3m )"
  17. src_prepare() {
  18. epatch \
  19. "${FILESDIR}"/${MY_P}-paths.patch \
  20. "${FILESDIR}"/${MY_P}-index.patch
  21. eprefixify ${MY_P}
  22. }
  23. src_install() {
  24. newbin ${MY_P} ${MY_PN}
  25. doman ${MY_PN}.1
  26. dodoc CHANGELOG KNOWN_BUGS README
  27. keepdir /var/cache/rfc
  28. }
  29. pkg_postinst() {
  30. elog "Gaarde suggests you make a cron.monthly to run the following:"
  31. elog " ${EPREFIX}/usr/bin/rfc -i"
  32. }
  33. pkg_prerm() {
  34. rm -f "${EROOT}"/var/cache/rfc/*
  35. }