xmlstarlet-1.5.0.ebuild 933 B

12345678910111213141516171819202122232425262728293031323334353637383940
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="4"
  4. DESCRIPTION="A set of tools to transform, query, validate, and edit XML documents"
  5. HOMEPAGE="http://xmlstar.sourceforge.net/"
  6. SRC_URI="mirror://sourceforge/xmlstar/${P}.tar.gz"
  7. LICENSE="MIT"
  8. SLOT="0"
  9. KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ppc ~s390 ~sh ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
  10. IUSE=""
  11. RDEPEND=">=dev-libs/libxml2-2.6.27
  12. >=dev-libs/libxslt-1.1.9
  13. dev-libs/libgcrypt:0
  14. virtual/libiconv"
  15. DEPEND="${RDEPEND}
  16. sys-apps/sed"
  17. src_configure() {
  18. # NOTE: Fully built documentation is already shipped with the tarball:
  19. # - doc/xmlstarlet-ug.{pdf,ps,html}
  20. # - doc/xmlstarlet.txt
  21. # - doc/xmlstarlet.1
  22. econf \
  23. --docdir="${EPREFIX}/usr/share/doc/${PF}" \
  24. --disable-build-docs \
  25. --disable-static-libs \
  26. --disable-silent-rules
  27. }
  28. src_install() {
  29. default
  30. dosym xml /usr/bin/xmlstarlet
  31. }