gist-7.3.ebuild 640 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2016 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit vim-plugin
  5. MY_PN=gist-vim
  6. MY_P=${MY_PN}-${PV}
  7. DESCRIPTION="vim plugin: interact with gists (gist.github.com)"
  8. HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2423 https://github.com/mattn/gist-vim"
  9. SRC_URI="https://github.com/mattn/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
  10. LICENSE="BSD"
  11. KEYWORDS="amd64 x86 ~x64-macos"
  12. RDEPEND="
  13. app-vim/webapi
  14. net-misc/curl
  15. dev-vcs/git
  16. "
  17. VIM_PLUGIN_HELPFILES="Gist.vim"
  18. S=${WORKDIR}/${MY_P}
  19. src_prepare() {
  20. default
  21. rm README.md gist.vim* Makefile || die
  22. }