libgnomecanvasmm-2.26.0-r1.ebuild 1.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657
  1. # Copyright 1999-2014 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI="5"
  4. GCONF_DEBUG="no"
  5. GNOME_TARBALL_SUFFIX="bz2"
  6. inherit flag-o-matic gnome2
  7. DESCRIPTION="C++ bindings for libgnomecanvas"
  8. HOMEPAGE="http://www.gtkmm.org"
  9. LICENSE="LGPL-2.1"
  10. SLOT="2.6"
  11. KEYWORDS="alpha amd64 arm ia64 ppc ppc64 ~sh sparc x86 ~x86-fbsd"
  12. IUSE="doc examples"
  13. RDEPEND="
  14. >=gnome-base/libgnomecanvas-2.6
  15. >=dev-cpp/gtkmm-2.4:2.4
  16. "
  17. DEPEND="${RDEPEND}
  18. virtual/pkgconfig
  19. doc? ( app-doc/doxygen )
  20. "
  21. src_prepare() {
  22. if ! use examples; then
  23. # don't waste time building the examples
  24. sed -i 's/^\(SUBDIRS =.*\)examples\(.*\)$/\1\2/' Makefile.in || \
  25. die "sed Makefile.in failed"
  26. fi
  27. gnome2_src_prepare
  28. append-cxxflags -std=c++11 #568300
  29. }
  30. src_compile() {
  31. gnome2_src_compile
  32. if use doc; then
  33. cd "${S}/docs/reference"
  34. emake all || die "failed to build API docs"
  35. fi
  36. }
  37. src_install() {
  38. gnome2_src_install
  39. if use doc ; then
  40. dohtml -r docs/reference/html/*
  41. fi
  42. if use examples; then
  43. cp -R examples "${D}/usr/share/doc/${PF}"
  44. fi
  45. }