cl-ppcre-2.0.11.ebuild 716 B

12345678910111213141516171819202122232425262728293031
  1. # Copyright 1999-2017 Gentoo Foundation
  2. # Distributed under the terms of the GNU General Public License v2
  3. EAPI=6
  4. inherit common-lisp-3
  5. DESCRIPTION="CL-PPCRE is a portable regular expression library for Common Lisp."
  6. HOMEPAGE="http://weitz.de/cl-ppcre/
  7. http://www.cliki.net/cl-ppcre"
  8. SRC_URI="https://github.com/edicl/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
  9. LICENSE="BSD-2"
  10. SLOT="0"
  11. KEYWORDS="~amd64 ~ppc ~sparc ~x86"
  12. IUSE=""
  13. RDEPEND="dev-lisp/flexi-streams"
  14. PDEPEND="dev-lisp/cl-ppcre-unicode"
  15. src_unpack() {
  16. unpack ${A} && cd "${S}"
  17. rm -rf cl-ppcre-unicode test/unicode*
  18. }
  19. src_install() {
  20. common-lisp-install-sources *.lisp test/
  21. common-lisp-install-asdf ${PN}
  22. dodoc CHANGELOG doc/index.html
  23. }